Issue with Service Catalog.

Incident Report for m102

Resolved

The issue was caused by an internal component related to our web services. It has been resolved, and the Service Catalog is now loading properly. We appreciate your patience and apologize again for any inconvenience.
Posted Apr 01, 2025 - 18:53 UTC

Investigating

We are actively investigating an issue affecting the loading of the Service Catalog in our Web Portal. We apologize for any inconvenience and will provide an update as soon as possible. Please note that no other services are impacted, and backups and restores triggered using the relevant clients will function normally.
Posted Apr 01, 2025 - 18:46 UTC
This incident affected: Web Portal (West Europe).