Office 365 backup errors

Incident Report for m102

Resolved

This incident has been resolved.
Posted May 22, 2025 - 01:54 UTC

Monitoring

A fix has been implemented and the Office 365 backup jobs are now running smoothly. Our team is actively monitoring the jobs to ensure continued performance and reliability. Thank you for your patience and understanding as we worked to resolve the issue. We will share further updates if necessary.
Posted May 21, 2025 - 09:34 UTC

Identified

We are currently rotating client secrets for Office 365 backup jobs, which may result in temporary access-related errors. Our team is actively validating the applications to ensure everything resumes normal operation as quickly as possible. Thank you for your patience.
Posted May 21, 2025 - 02:10 UTC